right ! <br><br><div class="gmail_quote">On Tue, Apr 27, 2010 at 09:36, Simon Rit <span dir="ltr"><<a href="mailto:simon.rit@creatis.insa-lyon.fr">simon.rit@creatis.insa-lyon.fr</a>></span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
After working a bit on clitk3, I have the feeling that there is<br>
absolutely no consistency between (and even within) files. I don't<br>
really think we should adopt a coding standard because we should keep<br>
our own coding styles but it would be nice if we could just set a<br>
minimal set of rules for the sake of readability. I suggest these ones<br>
first:<br>
- indentation: 2 spaces<br></blockquote><div><br>ok<br> </div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
- tabs are replaced by spaces<br></blockquote><div><br>ok, I have to search how to do that with emacs <br> </div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">

- opening and closing characters of a block are aligned vertically, e.g.<br>
if (true)<br>
{<br>
}<br></blockquote><div><br>ok, personaly I prefer: <br>if (true) {<br><br>}<br>because it save one line. But as you wish.<br><br> </div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">

- types are suffixed with Type (as in ITK if I'm not mistaking)<br></blockquote><div>ok<br> <br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">

- preprocessor defines and macros in upper case<br></blockquote><div>ok<br><br>I will add a few more : <br>- all member functions start with an upper case (like vtk and itk, but unlike QT !) : SetToto(a) and GetToto()<br>
- all member variables start with m, eg : mToto or mTiti (unlike vtk, unlike qt, unlike itk)<br>- delimitate the function (in cxx and txx) with comment like //------------ (see for example clitkBinarizeImageGenericFilter.txx)<br>
<br>that all for me. <br><br>If (when) we agree all : we can divide the repository, each of us will be responsible to modify a part of the source code according to the guideline.<br> <br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">


For the rest (e.g. naming of functions and variables), we can try to<br>
follow the rules of our third-party libraries (itk and vtk). What do<br>
you think?<br>
Simon<br>
_______________________________________________<br>
vv mailing list<br>
<a href="mailto:vv@creatis.insa-lyon.fr">vv@creatis.insa-lyon.fr</a><br>
<a href="http://www.creatis.insa-lyon.fr/mailman/listinfo/vv" target="_blank">http://www.creatis.insa-lyon.fr/mailman/listinfo/vv</a><br>
</blockquote></div><br><br clear="all"><br>-- <br>David Sarrut, Phd<br>Chargé de recherche CNRS<br>Centre de lutte contre le cancer Léon Bérard<br>28 rue Laënnec, 69373 Lyon cedex 08<br>Laboratoire CREATIS-LRMN UMR CNRS 5220, Inserm U 630<br>
Tel : 04 78 78 51 51 / 06 74 72 05 42<br><a href="http://www.creatis.insa-lyon.fr/rio">http://www.creatis.insa-lyon.fr/rio</a><br>______________________________________________<br> "2 + 2 = 5,  for extremely large values of 2"<br>
______________________________________________<br>